Central Administration via Group Policy

General talks about LiteManager utility.

Central Administration via Group Policy

Postby serg108 » 03 May 2019, 01:41

Hiya!

Can you kindly comment on my questions, thank you in advance!

My Environment:
- LM Server Version 4.8 (4864)
- 100 + servers


1. Is it possible to control LM settings Centrally via GPO/GPP (Group Policy Objects/Preferences)?

From what I'm reading all LM settings are stored in Registry under:
HKEY_LOCAL_MACHINE\SYSTEM\LiteManager\v3.4\Server\Parameters
and
HKEY_LOCAL_MACHINE\SYSTEM\LiteManager NoIpServer\Parameters

If I capture these Registry settings, with the exception of "ID (read only)" - can these settings be pushed to a number of computers via GPO/GPP?
So far I was not able to do that. Not sure what I'm doing wrong, settings do not take effect. I just want to confirm it is not bugged and it is possible to do it.

The only way I have found to do it - is to manually "Export settings XML" and Import them back. The perspective of doing this manually across 100+ servers is not pleasant.

2. Same question about the settings: Connect by ID > Options > Main> "Use public LiteManager NoIP Server" setting. Is this setting getting saved to:
HKEY_LOCAL_MACHINE\SYSTEM\LiteManager NoIpServer\Parameters
or in:
HKEY_LOCAL_MACHINE\SYSTEM\LiteManager\v3.4\Server\Parameters

3. Are there LM settings which are not stored in Registry and have to be input manually?
serg108
 
Posts: 9
Joined: 03 May 2019, 01:24

Re: Central Administration via Group Policy

Postby admin » 03 May 2019, 07:34

Hello!

1.
Settings of the LM Server stored in
HKEY_LOCAL_MACHINE\SYSTEM\LiteManager\v3.4\Server\Parameters
HKEY_LOCAL_MACHINE\SOFTWARE\LiteManager\v3.4\Server\Parameters (backup copy)

Yes, it is possible. Should works.

Possible changing LM Server settings remotely
http://www.litemanager.com/support/help ... _password/

2.
Same question about the settings: Connect by ID > Options > Main> "Use public LiteManager NoIP Server" setting. Is this setting getting saved to:

This settings saved to
HKEY_LOCAL_MACHINE\SYSTEM\LiteManager\v3.4\Server\Parameters in NoIPSettings parameters

3.
Yes, it is possible look at Compact version with the file Config.xml

Export settings in Config.xml, or create it as clear text file beside to ROMServer.exe. After copy this file to all of your LM Servers.

Clcik on Compact version, the file Config.xml will be created automatically. (after copy it to all other PCs)
Image
Best Regards LiteManagerTeam
admin
Администратор
 
Posts: 335
Joined: 07 Jun 2010, 13:19

Re: Central Administration via Group Policy

Postby serg108 » 13 May 2019, 03:00

Thank you for the answers.

3. It appears that config.xml does not store information for Connect by ID (Options)

LM_question.PNG
LM_question.PNG (8.32 KiB) Viewed 746 times


Can you please advise, how it can be changed via registry or some other config (other than manually changing this setting on local server)

The testing I have done is:

1. Configure Server#1
2. Enable Compact mode on Server#1
3. Copy config.xml from Server#1 to Server #2

After opening settings on Server #2 I can see most of my settings are identical to Server#1 but some are not.
"Connect by ID Options" settings are not getting cloned...

p.s.

To be exact, I want to remove/untick from all my servers "User public LiteManager NoIP Server"
serg108
 
Posts: 9
Joined: 03 May 2019, 01:24

Re: Central Administration via Group Policy

Postby admin » 13 May 2019, 06:08

The testing I have done is:

1. Configure Server#1
2. Enable Compact mode on Server#1
3. Copy config.xml from Server#1 to Server #2

After opening settings on Server #2 I can see most of my settings are identical to Server#1 but some are not.
"Connect by ID Options" settings are not getting cloned...

p.s.

To be exact, I want to remove/untick from all my servers "User public LiteManager NoIP Server"


All are right, just restart LM Server (or copy xml to Server #2 when it is stopped)
4. Restart LM Server
Best Regards LiteManagerTeam
admin
Администратор
 
Posts: 335
Joined: 07 Jun 2010, 13:19

Re: Central Administration via Group Policy

Postby serg108 » 29 May 2019, 02:30

Thank you. It does work for me now. I'm able to copy settings across multiple servers and it does update "Use public LiteManager NoIP Server" setting.
The trick was "Stop-LM-Server" before the coping config.xml file from source server to the destination server.

A follow-up question:

After Config.xml copied to the destination server, it wipes out "Protect setup parameters" on the destination server:
LM_question2.PNG
LM_question2.PNG (28.18 KiB) Viewed 602 times


So, I have to PasswordPprotect settings on the destination server each time Config.xml is copied/updated. Is there a way to preserve this setting?
Note: all servers have the same "Password Protect settings" password.
serg108
 
Posts: 9
Joined: 03 May 2019, 01:24

Re: Central Administration via Group Policy

Postby admin » 29 May 2019, 05:35

After Config.xml copied to the destination server, it wipes out "Protect setup parameters" on the destination server:

It is appear when user try to open LM Server's settings?
or during installation?

So, I have to PasswordPprotect settings on the destination server each time Config.xml is copied/updated. Is there a way to preserve this setting?
Note: all servers have the same "Password Protect settings" password.

Seems you turn on this option (Settings protection) and save it in Config.xml file, ?
Best Regards LiteManagerTeam
admin
Администратор
 
Posts: 335
Joined: 07 Jun 2010, 13:19

Re: Central Administration via Group Policy

Postby serg108 » 29 May 2019, 21:37

Good Morning,

The exact steps are as follows:

1. I have 2 servers which are configured identically, same version (4.8 4865), the same password is set for protection "Settings for LM Server"
2. On the "source" Server I make a change ( "Use public LiteManager NoIP Server" setting is changed) and I want to propagate this setting to "destination" server
3. On the "destination" server, I "Stop LM Server" and after that, I copy Config.xml from "source" server into "destination" server
4. After that I "Start-LM Server" on "destination" server and the following is happening:

a. Then I click on "Settings for LM Server" I notice it no longer password protected (as it used to be)
b. Under "Security>Authorization" instead of "WinNT Security" radio button, "Single password protection" button is selected
Note: I'm happy to say that "Use public LiteManager NoIP Server" and other settings are "cloned" as I wanted.

But apparently, security settings are reset during this process. Is there a way to preserve security settings?
serg108
 
Posts: 9
Joined: 03 May 2019, 01:24

Re: Central Administration via Group Policy

Postby admin » 30 May 2019, 04:45

All settings in the Config.xml file, on the first LM Server (as source) are used Password or Win NT security ?
Best Regards LiteManagerTeam
admin
Администратор
 
Posts: 335
Joined: 07 Jun 2010, 13:19

Re: Central Administration via Group Policy

Postby serg108 » 30 May 2019, 23:41

On a source server, we use: WinNT security
serg108
 
Posts: 9
Joined: 03 May 2019, 01:24

Re: Central Administration via Group Policy

Postby admin » 31 May 2019, 05:19

I have checked it, turn on WinNT security, turn on Compact version and Config.xml file was created, after copied it to other LM Sever and run it.
All correct, WinNT security is used.

Try before copy the Config.xml file, trun on WinNT security again.
Best Regards LiteManagerTeam
admin
Администратор
 
Posts: 335
Joined: 07 Jun 2010, 13:19

Next

Return to LiteManager: General Discussions

Who is online

Users browsing this forum: No registered users and 1 guest